Intermittent User Login Errors (USA only)

Incident Report for Keela

Resolved

This incident is resolved. Thank you for your patience while we worked to resolve the issue.
Posted Dec 04, 2025 - 16:46 PST

Monitoring

We have resolved the login errors and are continuing to monitor for any more issues. We apologize for the inconvenience.
Posted Dec 04, 2025 - 15:08 PST

Update

We are continuing to investigate this issue.
Posted Dec 04, 2025 - 14:38 PST

Investigating

We are investigating an issue that is causing intermittent user login errors.
Posted Dec 04, 2025 - 14:38 PST
This incident affected: Keela CRM (Keela CRM).