The backlog of events has finally caught up. This incident is resolved now. We thank you for your patience.
Posted Dec 16, 2025 - 10:15 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 08, 2025 - 15:57 PST
Update
Our system is still working through a large backlog of email events. We estimate that all email marketing statistics will be up-to-date within the next 7 days. We apologize again for the inconvenience caused.
Posted Dec 04, 2025 - 11:22 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 03, 2025 - 17:42 PST
Update
We are continuing to monitor as our system catches up with the processing of Email Marketing statistics. We thank you for your patience and apologize for the inconvenience caused.
Posted Dec 03, 2025 - 17:42 PST
Monitoring
Due to increased load, we are experiencing email marketing processing delays, but rest assured that emails are still being processed.
Posted Dec 02, 2025 - 12:32 PST
This incident affected: Keela CRM (E-mail Marketing Builder).