Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 07, 2026 - 20:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 06, 2026 - 13:59 PDT
Scheduled
We'll be performing scheduled maintenance on Keela's authentication system to support upcoming platform improvements. Keela may be unavailable for 10-15 minutes during this maintenance window โ users may be able to log in or access the platform.
Maintenance windows: ๐ฆ๐บ Australia (AUS): 10:00 AM Pacific Time (July 8, 3:00 AM AEST) ๐จ๐ฆ ๐บ๐ธ Canada & USA (CAN/USA): 8:00 PM Pacific Time (July 7, 11:00 PM ET) We've scheduled each region during its lowest-traffic window to minimize disruption. Thanks for your patience as we make these improvements โ we'll post updates here as the maintenance begins, progresses, and completes.
Posted Jul 06, 2026 - 13:58 PDT
This scheduled maintenance affected: Keela CRM (Keela CRM, Keela's Intelligence Tools, E-mail Marketing Builder) and E-mail Marketing (E-mail sending).