Canada Region Slow Loading Times

Incident Report for Keela

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 17:04 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 14:50 PDT

Investigating

We are currently experiencing some slowness in Keela CAN. You might see some things take a bit longer to load.
We are working to resolve this on our end ASAP.
We appreciate your patience and understanding during this time
Posted Apr 01, 2025 - 13:51 PDT
This incident affected: Keela CRM (Keela CRM), E-mail Marketing (E-mail sending), and Forms.