Scheduled recurring Paypal payments are failing

Incident Report for Keela

Resolved

The fix has been deployed, and recurring PayPal payments have been fully restored to normal operation.
Posted Sep 17, 2025 - 15:55 PDT

Identified

We’ve identified the root cause and are actively working on a fix. The update is scheduled to be deployed by the end of the day.
Posted Sep 17, 2025 - 14:39 PDT

Investigating

Scheduled recurring Paypal payments are failing with an pop up saying Payment Failed. Paypal payments are working as expected for one-time donation and revenue payments. We are investigating the root cause still and will provide more updates shortly.
Posted Sep 17, 2025 - 12:30 PDT
This incident affected: Keela CRM (Keela CRM) and Forms.