Mailchimp Disconnected

Incident Report for Keela

Resolved

This issue has been resolved. All customers should be able to reconnect their Mailchimp integration again. Note, that only Mailchimp users with admin and owner permissions will be able to connect the integration in Keela.
We thank you for your patience.
Posted Nov 05, 2025 - 09:51 PST

Monitoring

We have reset the connection in Keela for customers that disconnected as as a result of this issue. Please attempt to reconnect again. Note that customers may need to reconfigure merge fields again. We are still working with Mailchimp to understand the root cause of the issue.
Posted Nov 04, 2025 - 13:15 PST

Investigating

Please be aware that overnight, Mailchimp disconnected our customer accounts, and customers are currently unable to reconnect. We are in active discussions with Mailchimp to investigate the root cause and restore connectivity as soon as possible.
Posted Nov 04, 2025 - 10:18 PST
This incident affected: Keela CRM (Keela CRM).