Intermittent Performance Issues (CAN & USA)

Incident Report for Keela

Resolved

This incident is now resolved.
Posted Jul 16, 2026 - 13:55 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 16, 2026 - 13:54 PDT

Monitoring

A fix has been implemented, and we’re monitoring services to see whether it resolves the issue.
Posted Jul 03, 2026 - 13:08 PDT

Investigating

We are aware of intermittent performance issues affecting some customers in the US and Canada. Our team is actively investigating.
Posted Jul 03, 2026 - 11:25 PDT
This incident affected: Keela CRM (Keela CRM).