A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2026 - 09:22 PDT
Identified
We’re continuing to investigate intermittent instability on Keela USA. We’ve implemented some fixes and are continuing to investigate further to identify a long-term solution.
Posted Jul 17, 2026 - 13:43 PDT
Investigating
We're currently investigating the root cause of intermittent slowness on usa.keela.co.