This incident has been resolved and all systems are now operational.
Posted Dec 12, 2024 - 18:56 PST
Identified
We are currently experiencing some downtime on Keela USA. We are working to resolve this on our end ASAP. We appreciate your patience and understanding during this time.
Posted Dec 12, 2024 - 17:42 PST
Update
We are currently experiencing some downtime on Keela USA. We are working to resolve this on our end ASAP. We appreciate your patience and understanding during this time.
Posted Dec 12, 2024 - 17:41 PST
Investigating
We are currently experiencing some downtime on Keela USA. We are working to resolve this on our end ASAP. We appreciate your patience and understanding during this time.
Posted Dec 12, 2024 - 17:31 PST
This incident affected: Keela CRM (Keela CRM, Keela's Intelligence Tools, E-mail Marketing Builder) and Forms, Peer to Peer.