Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 10:00 PDT
Scheduled
We are informing you about an upcoming scheduled maintenance that will upgrade our Keela infrastructure.
What to Expect? During this time, there may be brief, intermittent downtime during the maintenance window.
Why are we doing this? These changes will enhance system reliability, strengthen security, and prepare our platform for future growth.
Schedule: October 21st at 9AM PST (or October 22nd at 3AM AEDT) ~ estimated time of 2 hours October 22nd at 10AM PST (or October 23nd at 4AM AEDT) ~ estimated time of 1 hour
Thank you for your understanding as we work to make Keela even better for you. If you have any questions or concerns, please don't hesitate to contact our support team at [email protected] Oct 20, 15:12 PDT
Posted Oct 21, 2025 - 16:59 PDT
This scheduled maintenance affected: Keela CRM (Keela CRM, Keela's Intelligence Tools, E-mail Marketing Builder), E-mail Marketing (E-mail sending), and Forms.