We are continuing to work on a fix for this issue.
Posted Feb 10, 2025 - 10:58 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 06, 2025 - 11:18 PST
Investigating
You may experience some delays within the Keela application when making contact updates, or during the import process. The updates and import validation steps are not being immediately reflected in the app. However, to help mitigate the issue, you can perform a refresh to the page and this should reflect your changes accordingly. Our developers are investigating this issue with urgency. We appreciate your patience and understanding during this time. Reach out to our Customer Support Team at [email protected] if you have any questions.