A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2025 - 19:40 PDT
Investigating
We are currently experiencing an issue where multiple services are down in our Canada Region. Our engineering team are investigating the issue to restore services as soon as possible.
Posted Jul 25, 2025 - 19:14 PDT
This incident affected: Keela CRM (Keela CRM, Keela's Intelligence Tools, E-mail Marketing Builder), E-mail Marketing (E-mail sending), and Forms, Peer to Peer, KeelaPay (USA Region).